Sie sind hier : Homepage →  Linux (1) Server-Installation→  Die Umlaute bei Suse 12.1 und putty

Bis opensuse 11.4 hatte es funktioniert, dann waren sie weg

Meine beiden Hauptprogramme innerhalb der putty console sind yast und midnight commander (und joe natürlich).

Irgendwann wurden die Umlaute nicht mehr korrekt dargestellt und alle Tricks halfen nichts.
.
Das hatte ich gefunden:

Problem: Irgendwan nach openSUSE 10.3 oder 11.4 traten bei einer SSH Verbindung mit Putty Fehler bei der Darstellung von Sonderzeichen insbesondere der Umlaute auf. Bis dahin funktionierte der "Latin1ISO-8859-1:1998 (Latin-1, West Europe)" Zeichensatz in Yast und mc unter Putty wunderbar.
.
Lösung:
Gefunden - Korrektur der Einstellung unter Putty:
.
Unter CONNECTION -> DATA -> TERMINAL-TYPE STRING muss der Wert XTERM mit dem Wert “linux” (Achtung: Diese Einstellung ist Case Sensitive. Das heißt “linux” in Kleinbuchstaben schreiben) ersetzt werden.
.
Weiterhin wurde bei Putty der Zeichensatz unter WINDOW -> TRANSLATION auf UTF-8 geändert.
.


Nun werden alle Umlaute und Linien, bei einer SSH Verbindung mit Putty, wieder korrekt dargestellt.

Das hier hatte nichts gebracht:
in /etc/ profile eintragen
.
export LANG=de_DE.UTF-8
export LANGUAGE=de_DE:de
export LC_ALL=de_DE.UTF-8


Doch das hier muss auf jeden Fall stimmen:  export TERM=xterm



Jetzt gehen einzelne F-Tasten im MC nicht mehr ??????????


Zurück zur Startseite ----- © 2009 / 2016 - Copyright by Dipl. Ing. Gert Redlich - Zum Telefon - - - - NEU : Zum Flohmarkt