Zur Vervollständigung der Geschichte hier die Daten von unserem Suse 8.2 Test-Server.

Aus historischen Gründen haben wir noch einen Suse 8.2 Sever am laufen.

 

Um jetzt alle Eventualitären abzuprüfen, haben wir auf unserem (offenen) DL380 G1 Spielserver, mit dem wir eigentlich nur Memory Tests laufen lassen und SCSI PLatten formatieren, nochmal Suse 8.2 installiert und snmp und hpasm zu installieren versucht.

 

Um es gleich vorweg zu nehmen, es war nicht einfach. Es dauerte einen ganze Tag, um aus allen verfügbaren Informationen die Richtigen raus zu suchen. Teilweise standen sie in englisch auf dem japanischen HP Server.

 

Aber endlich Erfolg: er läuft mit den üblichen Macken.

 

Hier die "verketteten" Versionen, die unter Suse 8.2 auf dem DL 380 laufen:

Das ist schon etwas für versierte Linuxer, die mit den Interna von Suse 8 umgehen können. (Ich hatte mich schon sehr schwer getan, denn so gut bin ich nicht.)

 

Also:

Suse 8.2 mit Kernel : "kernel version 2.4.20-4GB"

mit : Intel(R) PRO/100 Network Driver - version 2.1.29-k3

 

der snmp Dämon (von der Suse 8.2 CD über yast instaliert) ist der :

UCD-SNMP version 4.2.6 (der eigentlich nie richtig ging)

 

Hier zwischen liegen eine Reihe von Ergänzungen von Linux Suse 8.2 Kernel-Sourcen und anderen Hilfskrücken, aber nicht alle mit yast installiert.

 

z.B. kernel-source-2.4.20.SuSE

denn diese Version hatte beim Installieren das angemeckert als missing .....

hpasm-6.20.0-14.SLES7.i386.rpm

 

nur, diese Version von hpasm 6.20 läuft gar nicht richtig, läßt sich auch nicht mehr deinstallieren, bereitet aber die Version 7.5 vor. Ohne die 6.20 als erfolgloser Versuch startet die 7.5 nicht (komisch ist das).

die Update Installation geht mit diesen Optionen

rpm -Uhv hp................

 

aber da war nocht etwas konfuses dazwischen ..........

 

Die bei uns am Ende funktionierende Compaq-HP Installationsdatei heißt:

hpasm-7.5.1-8.sles8.i386.rpm

mit der Kennung : hpasm Version 7.5.1-Custom

 

sowohl "./snmpd start" wie auf "./hpasm start" lassen sich in

/etc/init.d/  jeweils mit ./snmpd start usw. aufrufen (laden)

 

Anfang mit hpasm 6.20, dann 7.1 drüber bügeln

erst mal ins Unreine geschrieben :

 

/opt $ rpm -Uvh hpasm-7.5.1-8.sles8.i386.rpm

Stopping HP Server Management Drivers and Agents, please wait ...

This release of hpasm cannot be installed because it will conflict with a package already installed. Please remove the current hpasm or cpqhealth that is installed before upgrading to this release.

Use 'rpm -e' to remove the old package.

execution of hpasm-7.5.1-8.sles8 script failed, exit status 1

 

[www3.ipw.net/ssl - root] /opt $ rpm -e hpasm-6.20.0-14.SLES7.i386.rpm

error: package hpasm-6.20.0-14.SLES7.i386.rpm is not installed

 

uninstallieren wollte rpm auch nicht !!

 

das geht also so nicht, aber so :

 

[www3.ipw.net/ssl - root] /opt $ rpm -Uvh hpasm-7.1.0-145.ul10.i386.rpm

Stopping HP Server Management Drivers and Agents, please wait ...

Starting hpasm package Upgrade. . .

find: /opt/compaq/cpqhealth/cmhp/*: No such file or directory

hpasm                       ##################################################

Completing hpasm package Upgrade. . .

Stopping HP Server Management Drivers and Agents, please wait ...

Please read the Licence Agreement for this software at

         /opt/compaq/hpasm/hpasm.license

By not removing this package, you are accepting the terms

of the "License for HP Value Added Software".

=================================================

NOTE: In order to activate the software contained in this package, you must

      type 'hpasm activate' as 'root' user.

      You may subsequently reset your agent configuration by typing

      '/etc/init.d/hpasm configure' or '/etc/init.d/hpasm reconfigure'.

=================================================

The hpasm RPM has installed successfully.

cannot remove /opt/compaq/webagent/sysgen - directory not empty

removal of /opt/compaq/cpqhealth/cpqevt/2.4.7-64GB-SMP/cpqevt.o failed: No such file or directory

removal of /opt/compaq/cpqhealth/cpqevt/2.4.7-4GB/cpqevt.o failed: No such file or directory

removal of /opt/compaq/cpqhealth/cpqasm/2.4.7-64GB-SMP/cpqasm.o failed: No such file or directory

removal of /opt/compaq/cpqhealth/cpqasm/2.4.7-4GB/cpqasm.o failed: No such file or directory

[www3.ipw.net/ssl - root] /opt $

 

 

 

die hpasm Version 7.1 hat es gemacht, ohne vorher zu löschen drüber installieren (wir sprechen dann von drüber bügeln)

jetzt kommt "hpasm activate"

 

Agent Startup Policy

1 - No agents shall run on startup

2 - Web agent shall not run on startup

3 - All agents shall run on startup

(Enter digit 1,2 or 3): 1

 

wir starten das hpasm beim booten vorerst von hand !!

 

======================================================

NOTE: New cma.conf entries were added to the top of /opt/compaq/cma.conf

======================================================

Starting HP Server Management Drivers and Agents, please wait ...

Replacing /opt/compaq/cpqhealth/cpqevt/2.4.20-64GB-SMP/cpqevt.o at Thu Nov 22 01:13:14 CET 2007 . . .

Custom cpqevt Driver installed  . . .

Reloading the hp ProLiant Advanced Server Management Event module . . .

The hp ProLiant Advanced Server Management Event module (cpqevt.o) has rebuilt and has loaded successfully.

Replacing /opt/compaq/cpqhealth/cpqasm/2.4.20-64GB-SMP/cpqasm.o at Thu Nov 22 01:13:15 CET 2007 . . .

Custom Health Driver installed  . . .

Reloading the hp ProLiant Advanced Server Management module . . .

The hp ProLiant Advanced Server Management module (cpqasm.o) has rebuilt and has loaded successfully.

casmd: hp ProLiant Advanced Server Management Monitoring . . .

cevtd: hp ProLiant Event Logging daemon started . . .

 

so richtig geht es immer noch nicht, weil ich die V7.5 nicht installiert bekomme.

 

Also noch mal die 7.1 drüber "bügeln".

Nochmal die 7.1 drüber

[www3.ipw.net/ssl - root] /opt $ rpm -Uhv --force hpasm-7.1.0-145.ul10.i386.rpm

Stopping HP Server Management Drivers and Agents, please wait ...

Starting hpasm package Upgrade. . .

hpasm                       ##################################################

Completing hpasm package Upgrade. . .

Stopping HP Server Management Drivers and Agents, please wait ...

Please read the Licence Agreement for this software at

         /opt/compaq/hpasm/hpasm.license

By not removing this package, you are accepting the terms

of the "License for HP Value Added Software".

=================================================

NOTE: Your SNMP configuration is distributed over various configuration files.

      This may result in operational problems with this package.

      As a precaution, all secondary configuration files were renamed to ensure

      that HP management software interoperates with SNMP properly.

      If important settings are contained in the files listed below, please

      transfer them to /usr/share/snmp/snmpd.conf, the primary configuration file.

      Renamed /etc/snmpd.conf to /etc/snmpd.conf.bak

=================================================

=================================================

NOTE: Your SNMP stack can load the hp ProLiant Management Extension (cmaX).

      Problems may result from using your distribution's SNMP stack.

      See hp Documentation (HOWTO, agent manual) for more details.

=================================================

=================================================

NOTE: New cma.conf entries were added to the top of /opt/compaq/cma.conf

=================================================

Following environment variables were used to configure snmpd/agents:

    CMAAGENTEXCLUDESTR

Starting HP Server Management Drivers and Agents, please wait ...

Replacing /opt/compaq/cpqhealth/cpqevt/2.4.20-64GB-SMP/cpqevt.o at Thu Nov 22 01:33:41 CET 2007 . . .

Custom cpqevt Driver installed  . . .

Reloading the hp ProLiant Advanced Server Management Event module . . .

The hp ProLiant Advanced Server Management Event module (cpqevt.o) has rebuilt

and has loaded successfully.

Replacing /opt/compaq/cpqhealth/cpqasm/2.4.20-64GB-SMP/cpqasm.o at Thu Nov 22 01:33:42 CET 2007 . . .

Custom Health Driver installed  . . .

Reloading the hp ProLiant Advanced Server Management module . . .

The hp ProLiant Advanced Server Management module (cpqasm.o) has rebuilt

and has loaded successfully.

casmd: hp ProLiant Advanced Server Management Monitoring . . .

cevtd: hp ProLiant Event Logging daemon started . . .

The hpasm RPM has installed successfully.

 

Achtung:

wieder ist bei dieser Installation von SNMP /etc/snmpd.conf leer oder kaputt, also reparieren. Bei der von Suse in der Version 10.x mitgelieferten net-snmp Version ist die snmp.conf Datei in /etc/snmp/ (und nicht in /etc/) und wird beim Deinstallieren nicht mit gelöscht. Eine Kopie der snmp.conf ist auf jeden Fall hilfreich.

 

Übrigens: Deinstallieren von hpasm geht ganz einfach (wenn man es weiß) als "su" von jedem Verzeichnis aus.

rpm -e hpasm

auf die 7.5 updaten, wegen der storage driver

[www3.ipw.net/ssl - root] /opt $ rpm -Uvh hpasm-7.5.1-8.sles8.i386.rpm

Stopping HP Server Management Drivers and Agents, please wait ...

This release of hpasm cannot be installed because it

will conflict with a package already installed.

Please remove the current hpasm or cpqhealth that

is installed before upgrading to this release.

Use 'rpm -e' to remove the old package.

execution of hpasm-7.5.1-8.sles8 script failed, exit status 1

 

 

so gehts nicht

 

[www3.ipw.net/ssl - root] /etc/init.d $ ./hpasm stop

Shutting down Server Agents (cmasvr):

Shutting down Foundation Agents (cmafdtn):

The hp ProLiant Advanced Server Management Daemon is already stopped.

The hp ProLiant Event Logging Daemon is already stopped.

The hp ProLiant Advanced Server Management Driver is already stopped.

The hp ProLiant Event Logging Driver is already stopped.

Advanced Server Management has been disabled successfully.

 

die Reihenfolge stimmt nicht !! <br>update auf 7.5 geht jetzt nicht mehr ????

also erst mal den storage agent probieren

 

[www3.ipw.net/ssl - root] /opt $ rpm -Uvh --force cmastor-7.1.0-12.linux.i386.rpm

Warning: your Linux distribution/version had not been tested with this RPM!

Warning: your Linux distribution/version had not been tested with this RPM!

cmastor                     ##################################################

cmastor installation: snmpd Start script is detected at runlevels 2 3 4 5

cmastor installation: cmastor Start script is installed at runlevels 2 3 4 5

 

=================================================

NOTE: Storage agents do not automatically start. Use the following

      command to start up the storage agents:

      /etc/init.d/cmastor start

=================================================

 

/etc/init.d/cmastor start

 

Mit allen Tricks arbeiten - auch volles Risiko

Der Stein der Wahrheit: Immer erst am Testobjekt probieren, ehe man in die Produktion einsteigt.

 

Bevor man dieses Kommando aufruft, muß man in den rc Verzeichnissen alle hpasm und cmastor aufrufe entfernen.

und in /opt/compaq/ alle Unterverzeichnisse und Dateien !!

 

[www3.ipw.net/ssl - root] /opt $ rpm -Uvh --force hpasm-7.5.1-8.sles8.i386.rpm --nodeps

dann kommen auch wieder viele Fehler

 

eventuell das auch entfernen     rpm -e cmastor

 

dann kommen viele fehler, aber dann

 

[www3.ipw.net/ssl - root] /opt $ rpm -Uvh --force hpasm-7.5.1-8.sles8.i386.rpm --nodeps

Stopping HP Server Management Drivers and Agents, please wait ...

Starting hpasm package Upgrade. . .

hpasm                       ##################################################

Completing hpasm package Upgrade. . .

Stopping HP Server Management Drivers and Agents, please wait ...

Please read the Licence Agreement for this software at

         /opt/compaq/hpasm/hpasm.license

By not removing this package, you are accepting the terms

of the "License for HP Value Added Software".

=================================================

NOTE: In order to activate the software contained in this package, you must

      type 'hpasm activate' as 'root' user.

      You may subsequently reset your agent configuration by typing

      '/etc/init.d/hpasm configure' or '/etc/init.d/hpasm reconfigure'.

=================================================

The hpasm RPM has installed successfully.

 

Hier ein Ausschnitt aus dem Bootprotokoll unseres ersten Suse 8.2 Servers, .....

wenn hpasm den Server runter fährt, weil hinten der große CPU- und Gehäuse-Lüfter zu langsam dreht, und damit die CPUs zu heiß werden, dann aber diesen Lüfter nicht mehr "hoch" regelt, sondern dafür den Server killt, das ist Mist !!

 

Nov 21 20:44:06 linuxsuse8 hpasmd[9095]: WARNING: hpasmd: Automatic Operating System Shutdown Initiated Due to Fan Failure

Nov 21 20:44:06 linuxsuse8 hpasmd[9095]: WARNING: hpasmd: Fan Failure (Fan 1, Location CPU) - (das ist der hintere große Chassis Lüfter)

 

Nov 21 20:45:06 linuxsuse8 init: Switching to runlevel: 6

Nov 21 20:45:08 linuxsuse8 sshd[426]: Received signal 15; terminating.

Nov 21 20:45:17 linuxsuse8 hpasmd[9049]: ProLiant System Health Monitor unloading

Nov 21 20:45:39 linuxsuse8 kernel: Kernel logging (proc) stopped.

Nov 21 20:45:39 linuxsuse8 kernel: Kernel log daemon terminating.

Nov 21 20:45:40 linuxsuse8 exiting on signal 15

 

Hier macht der Server seinen BIOS Selbst-Test

 

Nov 21 20:47:57 linuxsuse8 syslogd 1.4.1: restart.

Nov 21 20:47:59 linuxsuse8 hpasmd[751]: ProLiant System Health Monitor loading

Nov 21 20:48:01 linuxsuse8 modprobe: modprobe: Can't locate module char-major-10-220

Nov 21 20:48:01 linuxsuse8 last message repeated 2 times

Nov 21 20:48:02 linuxsuse8 kernel: klogd 1.4.1, log source = /proc/kmsg started.

Nov 21 20:48:02 linuxsuse8 kernel: Inspecting /boot/System.map-2.4.20-4GB

Nov 21 20:48:02 linuxsuse8 kernel: Loaded 20952 symbols from /boot/System.map-2.4.20-4GB.

Nov 21 20:48:02 linuxsuse8 kernel: Symbols match kernel version 2.4.20.

Nov 21 20:48:02 linuxsuse8 kernel: Loaded 180 symbols from 7 modules.

Nov 21 20:48:02 linuxsuse8 kernel: Intel(R) PRO/100 Network Driver - version 2.1.29-k3

Nov 21 20:48:02 linuxsuse8 kernel: Copyright (c) 2002 Intel Corporation

Nov 21 20:48:02 linuxsuse8 kernel: e100: selftest OK.

Nov 21 20:48:02 linuxsuse8 kernel: e100: eth0: Compaq Fast Ethernet Server Adapter

Nov 21 20:48:02 linuxsuse8 kernel:   Hardware receive checksums enabled

Nov 21 20:48:02 linuxsuse8 kernel:   cpu cycle saver enabled

Nov 21 20:48:02 linuxsuse8 kernel: raw1394: /dev/raw1394 device initialized

Nov 21 20:48:02 linuxsuse8 kernel: e100: eth0 NIC Link is Up 100 Mbps Half duplex

Nov 21 20:48:02 linuxsuse8 /usr/sbin/cron[1114]: (CRON) STARTUP (fork ok)

Nov 21 20:48:04 linuxsuse8 sshd[1171]: Server listening on :: port 22.

 

und jetzt geht SSH schon wieder.

das muss alles nochmal gerichtet werden, war nur schnell mitten im Stress reingeklopft, weil sonst die Bildschrimanzeigen weg sind.

Ich habe alles durch Probieren auf unserem "Spielserver" raus bekommen, das ist sehr zeitaufwändig und stressig. Und hüten Sie  sich davor, es auf einer Produktionsmaschine zu machen.

 

Aber es geht jetzt auf zwei Servern, sogar mit Suse 8.2 und net-snmp 5.4 von Redhat und auf dem anderen mit Suse's udc-snmp 4.1.2.

 

Und natürlich auch auf Suse 9.2 und sogar 10.2 (das aber wiederum nicht auf Compaq DL 380 Servern) und Debian 4.0 jeweils mit den per apt-get mitgelieferten snmp daemons.

 

Das alles sollte nur zeigen, daß man mit einer gewissen (bösartigen) Sturheit und Hartnäckigkeit irgendwann zum Ziel kommt. Und wenn man nicht alles haargenau und lückenlos protokolliert, geht es irgendwie, nur keiner weiss mehr wie und warum.

 

Also eigentlich Finger weg von Suse 8.2, das ist out.

Hier die hpasm Dateinamen, die wir haben:

hpasm-7.3.0c-67.ul10.i386.rpm

hpasm-7.3.0c-67.ul10.i386-sus.rpm.txt

hpasm-7.5.1-8.sles8.i386.rpm

hpasm-7.5.1-8.sles8-24627.txt

 

und hier der Text mit wichtigen Kommandos zum Deinstallieren

hpasm-7.3.0c-67.ul10.i386-suse8.rpm.txt

Filename: hpasm-7.3.0c-67.ul10.i386.rpm

Title: HP Server Management Application and Agents for SUSE LINUX Enterprise Server 8 (x86)
Version: 7.3.0c-67
Language: English
Category: Driver - System Management
Division: Industry Standard Servers

Operating Systems: SUSE LINUX Enterprise Server 8 (x86)
System Configuration: All shipping configurations
Prerequisites: N/A
Effective Date: 6/24/05
Electronic Distribution Allowed: YES

Description:
This RPM is used to provide server management capabilities for SUSE LINUX Enterprise Server 8 (x86) installed on supported server systems.

Enhancements:  
- Fixed an issue that Smart Array agent (cmaidad) may keep sending invalid inquiry to Smart Array P600 SAS RAID controller.

- Fixed an issue that Smart Array agent (camidad) and Event Daemon (cmaevent) may consume lots of CPU time on ProLiant servers that have more than 4GB of memory.

- Resolved possible segmentation fault with agent daemon when specific data files were accessed.

- Added additional RPM naming conventions to specify Linux Distribution.  This allows automated placement of files for deployment tools (such as Red Hat Satellite Server) that attempt to put deliverables in the following format:  /var/satellite/NAME-VERSION-RELEASE.

Notes  
The HP Server Management Application and Agents contain the following drivers and agents:

Advanced Server Management application (Health Driver)
Integrated Management Log (IML) Viewer Application
Foundation Agents
Health agent (formerly in the Server Agents package)
Standard equipment agent (formerly in the Server Agents package)
Server peer agent (formerly in the Server Agents package)
Storage agents

The Advanced Server Management (health) driver can be recompiled on a non-default (or errata) Linux Kernel. If you would like to install or create the RPM for a non-default kernel, you must also install the kernel sources for your compiled kernel. In addition, the development packages required for rebuilding a kernel need to be present.  

Installation  

Login as the system administrator (root), download the RPM to a directory on your hard drive and change to that directory.

If a previous version of the Health Driver or Insight Management agents has been installed, they must be removed before this package can be installed. Any packages dependent on the Health Driver must also be removed. To check which version of the Health Driver (if any) is on the system, type:

rpm –q hpasm

The rpm -q command may also be used to check for the existence of dependent packages. There is no need to uninstall packages that are not present on the system.

To remove the previous version and any packages dependent on it, type the following, in order:

rpm –e cmanic
rpm –e hprsm
rpm –e hpasm

NOTE: You should update your snmp agents prior to installing the hpasm package.

To install the package, type:
rpm -ivh hpasm-< version >.rpm

The application and agents will be installed immediately. The NIC Agents must be downloaded and installed separately.

To check whether the package is loaded properly, type:

/etc/init.d/hpasm status

You should see entries for the following:

hpasmd – Health Application

Status of Foundation Agents (cmafdtn): cmawebd cmathreshd cmahostd cmapeerd
cmathreshd
cmahostd
cmapeerd

Status of Server Agents (cmasvr): cmastdeqd cmahealthd cmaperfd
cmastdeqd
cmahealthd
cmaperfd

Status of Storage Agents (cmastor): cmaeventd cmaidad cmafcad cmaided cmascsid
cmaeventd
cmaidad
cmafcad
cmaided
cmascsid (if server has a SCSI controller supported by agents)

If you attempt to install the RPM on an unsupported system, you will get an error message. The driver will not be operational and it is advisable to uninstall the driver at your earliest convenience.

Running the health driver:
Once installed, the health driver will be automatically loaded every time the server boots. Several /proc entries are available when the driver is running.

Additional information and help is available by typing:

man hpasm

Running the agents:
The agents require an SNMP stack to be available. If SNMP support is not installed on the system, the agents will not load. In this case, either install the SNMP stack delivered on the OS media, or download the SNMP stack available on www.compaq.com/support/files/server/us/. If the agents are not loaded, the health driver will still function normally.

Running the IML Viewer Application:
The HP ProLiant Integrated Management Log (IML) Viewer is an application that runs in the X-Windows environment. Execute the following command to start the IML Viewer:

cpqimlview

The hp ProLiant Integrated Management Log Viewer automatically displays the current entries of the Integrated Management Log.

Additional information and help is available by typing:

man cpqimlview

Previous versions of the health driver and agents are available on ftp.compaq.com. To ensure the latest technology and bug fixes, HP recommends the use of this package over previous versions of the driver and agents.

MD5 CHECKSUM:
10435888e4c27cdc14339ccf7f90253b  hpasm-< version >.ul10.i386.rpm

Additional information about features, installation, use, and troubleshooting the HP Server Management Drivers and Agents is available in the HOWTO documents available here: www.compaq.com/products/servers/linux/documentation.html.

systems supported 

family   models  
HP ProLiant BL45p   All Models  
HP ProLiant BL40p   All Models  
HP ProLiant BL35p   All Models  
HP ProLiant BL30p   All Models  
HP ProLiant BL25p   All Models  
HP ProLiant BL20p   G3, G2, (1.4GHz)  
HP ProLiant BL10e   G2, (700-900MHz)  
HP ProLiant DL760   (700-900MHz)  
HP ProLiant DL580   G2, (700-900MHz)  
HP ProLiant DL385   All Models  
HP ProLiant DL380   G4, G3, G2, (667-1000MHz), G4 Packaged Cluster with MSA1000  
HP ProLiant DL360   G4 / G4p, G3, G2, (550-1266MHz)  
HP ProLiant DL320   G3, G2, (800-1.5GHz)  
HP ProLiant ML750   All Models  
HP ProLiant ML570   G2, (667-1000MHz)  
HP ProLiant ML530   G2, (667-1000MHz)  
HP ProLiant ML370   G4, G3, G2, (600-1000MHz)  
HP ProLiant ML350   G4 / G4p, G3, G2, (667-1000MHz)  
HP ProLiant ML330e   All Models  
HP ProLiant ML330   G2, (667-999MHz)  
HP ProLiant ML310   G2, (2.0-2.2GHz) 

 

Ende dieses Textes. Dieser Text dient nur zur Information.

Wir haben März 2008 und darum: Finger weg von der Suse 8

Nach oben

Zurück zur Startseite ----- © 2009 / 2018 - Copyright by Dipl. Ing. Gert Redlich - Zum Telefon - - - - NEU : Zum Flohmarkt