Sie sind hier : Homepage →  Linux (6) Ein Webtropia root-Server

Ein neuer Anlauf bei Webtropia - ein "dedicated root Server"

10.12.2016 - Nach der Enttäuschung bei Hetzner - trotz aller vorher getätigten Vorabinformationen - habe ich mich jetzt nochmal eingehend kundig gemacht, was die Wettbewerber für meine (Virtualisierungs-) Anforderungen anbieten. Gefordert ist also ein eigener physikalischer root-Server mit zukünftig einem XEN- Hypervisor und 6 oder 8 "VMs = Virtuellen Maschinen" drauf.

Bei webtropia werden die Angebote für "root Server" nochmals unterschieden. Ich benötige also einen "dedicated root server", die anderen dort angebotenen root-Server sind bereits sogenannte "V-Server", die schon virtualisiert sind und damit keinen weiteren Hypervisor mehr oben drauf ermöglichen/erlauben. Auch das muß man vorher erfragen bzw. wissen, damit es nicht mit den eigenen Anforderungen kollidiert.
.

Die Bestellung geschieht über ein Web-Formular

In dem Web-Formular auf deren Homepage wird während der Bestellung auf mehreren Seiten alles Wichtige abgefragt und dann bekommt man eine Bestätigung und die Aufforderung, sich zu autentifizieren, bzw. seine Identität nachzuweisen.

Meine Bestellung ist am Samstag um ca. 22.oo raus gegangen und am Sonntag !!! hatte ich bereits die Bestätigung samt der Passwörter. Ich hatte mein Impressum auf den www.RDE.net Seiten angegeben. Das ist wirklich beachtlich.

Jetzt könnte es also losgehen mit der Installation des opensuse 13.2 XEN Hypervisors, der Partitionierung der RAID1 Festplatte sowie der ersten VM. Ich bin wirklich gespannt. Übrigens, beim technischen Support gibt es - wie auch bei Hetzner - reale Personen mit Namen als Ansprechpartner, das gefällt mir.
.

Was bei Hetzner das Wiki war, sind hier die FAQs

Auch hier sind manche Hilfen schon etwas älter, aber man kann sich daran orientieren und festhalten. Ich habe hier eine dieser Hilfen für meine Zwecke (opensuse + XEN) überarbeitet.
.

Die Aufgabe: Wie installiere ich ein (eigenes) opensuse 13.2 (NET)-Image ohne eine "Hardware Console over IP" ?

Wenn Sie ein eigenes opensuse Image installieren möchten, z.B. um eine eigene Partitionierung vorzunehmen, ist dies bei einigen Betriebssystemen auch ohne Hardware KVM (Kernel based Virtual Machine) over IP möglich. Laut FAQs  sind mindestens 4 GB Arbeitsspeicher Voraussetzung, da das Installations- ISO-Image in den Arbeitsspeicher geladen wird. (Hier haben wir 32 GB!)
.

Doch aufpassen, es gibt Fallstricke

Ganz wichtig ist, daß bei der Bestellung des Servers ein (initiales) Betriebssystem ausgewählt werden kann (und muß !) und daß dieses (vermutlich) auf Knopfdruck fertig auf dem Server (auf den gespiegelten RAID1 Serverplatten) installiert wird.

Da ich da anfänglich etwas zu schnell agiert hatte, haben mir die Supporter das später nochmal installiert. Das ist aus jetziger Sicht ganz wichtig, denn da hat man zumindest eine problemos laufende "opensuse 13.2" Grund-Installation.

Ich hatte nämlich gleich mal den sogenannten Rescue-Modus "angeworfen" und die auf der Festplatte (unbekannter Weise) vorhandene opensuse 13.2 Grund-Installation, von deren Existenz ich keine Ahnung hatte, mit eigenen Vorstellungen einer opensuse 13.2 überschrieben - und das war nicht gut.
.

Darum als Tip, wenn der Server bereitgestellt wurde . . .

Nach dem Miet-Auftrag (also der online-Bestellung) über das Webformular möchte "myloc managed IT AG" eine seriöse Authentifizierung, daß Sie auch derjenige sind, für den Sie sich ausgeben. Das bedeutet, Sie bekommen Ihr Zugangs-Passwort für die Weboberfläche des ZKM (= "Zentrales Kundenmanagement" von webtropia) per Post an die angegeben Adresse verschickt. Voher geht erst mal gar nichts.

Wichtig : Diese Kontroll- und Administrations- Weboberfläche funktioniert nur mit bestimmten aktuellen Browsern richtig, mit dem Firefox 33 und darunter geht es schon nicht mehr. Mit dem Firefox 46 geht es dann. Auch manche Opera's haben Probleme.

Auf dieser Kundenmanagement-Seite Ihres dedizierten Servers finden Sie dann die Haupt-IP Nummer des Servers. Auf der Server-Bestell- Bestätigungs-E-Mail finden Sie erstaunlicher Weise ein Klartext-Passwort, mit dem Sie sich - aber nur auf dieser ZKM Webseite (deren Passwort kommt per Brief !) - für diesen Server das (ssh-putty) root Passwort anzeigen lassen können - und zwar nur einmal, dann nie wieder. Diese Verkettung von Passwörtern ist anfänglich schwer zu verstehen (also wofür das Passwort in der Mail gedacht ist), vor allem, wenn Sie - wie bei mir - den Brief mit dem Zugangs-Passwort zum ZKM-Kundenmanagement noch gar nicht bekommen haben. Diesen Brief müssen Sie nämlich auch erst mal selbst anfordern, auch über die Kundenmanagement-Seite - beim ersten Anmeldeversuch. Von alleine kommt der Brief nicht.
.

Diese oben beschriebene erste Mail sagte :
"Die Neuinstallation Ihres Servers ist abgeschlossen"

Das bedeutet (wußte ich erst später), auf dem Server ist bereits eine funktionierende "opensuse 13.2" Grund-Installation mit der für diesen Server vergebenen IPV4-Nummer (statisch - kein DHCP) fertig installiert. Und mit Hilfe des nun abgeholten root-Passworts kommen sie auf Ihren Server mit "putty" sofort drauf.

Jetzt endlich können sie mal schaun, wie gut und wie schnell die Anbindung und der webtropia Server wirklich ist. - Er sit sehr sehr schnell !! - Auch können Sie diese Grund-/ Erst-Installation und die RAID1- Festplatten-Konfiguration genauer durchleuchten, ob die für die (Ihre) XEN-Virtualisierungszwecke geeignet ist.

Auf jeden Fall sollten / müssen Sie die wesentlichen Konfigurationsdateien des Netzwerkes und der beiden gespiegelten RAID1 Platten (/etc/fstab) und den Inhalt der beiden bereits angelegten Partitionen sichern.

Und das machen Sie offline mit der Rescue-Funktion und der dann nacheinander offline gemounteten "/boot" und "/" root-Partition.
.

Beim Webtropia/myloc Support braucht man etwas Geduld.

Manchmal geht es schnell, manchmal dauert es leider sehr lange.
Beispiel :
5.1.2017 - 23.oo Uhr - Die Remote-Reset Funktion auf der Webseite ist scheinbar abgestürzt. Der Server kommt so oder so nicht mehr hoch. Auch mehrfaches Wechseln von Rescue und non Rescue mit nachfolgendem RESET, jeweils mit 5 Min Abstand, führt nicht zum Erfolg. Schade.

6.1.2017 - 5.40 Uhr - Der Suport verspricht schnelle Hilfe beim Reset-Probelm

6.1.2017 - 15.00 Uhr - Der Reset dieses Server funktioniert immer noch nicht. (Ich wußte anfänglich nicht, daß bei diesem "Server" der shutdown Befehl die "ganze Kiste" physikalisch abschaltet.) Ich habe nochmals per Ticket nachgefragt.

Jetzt wird es mühsam, das zu verstehen. Wie gesagt, ich plane hier eine Produktionsumgebung, die auf meinen eigenen beiden HP DL 385 Servern seit 8 Jahren läuft.

6.1.2017 - 17.oo Uhr - Der Server ist wieder da = mit ping ansprechbar

Hier geht es weiter mit meiner Erfahrung und den Hilfen.
.

Oder Sie gehen direkt auf diese Unterseiten

.

Zurück zur Startseite ----- © 2009 / 2016 - Copyright by Dipl. Ing. Gert Redlich - Zum Telefon - - - - NEU : Zum Flohmarkt