Sie sind hier : Homepage →  und hier lauter alte Storys→  Die T-DSL Story

Sie möchten schmunzeln oder schallend lachen ? Hier sind Sie richtig. Eine scheinbar unendliche Geschichte:

(der arbeitende) Sinus 154 Basic-3 funktionierte über Jahre

Die Sachlage:
Es ist der Juni 2008 - Hier bei RDE habe ich seit Januar 2006 das asymmetrische Telekom T-DSL 6000 der "Telekommer". Dazu habe ich einen Sinus 154 Basic-3 Router mit W-Lan und WAP2 und es funktioniert wunderbar. Da ich damals gehört hatte, daß die "Telekommer" nicht immer ganz so schnell "kommen", wenn es brennt, habe ich mir 4 weitere Telekom Sinus 154 Basic-3 im ebay gekauft und alle 3 mit unserer letzten Master-Konfiguration seit Anbeginn komplett "vorkonfiguriert" im Schrank liegen. (Man weiß ja nie.)

Die Verlockung:

Das Telefon klingelt am 3.Juni 2008 und der freundliche Kundenbrater Herr M. ist dran und möchte mir den kostenfreien den Umstieg von Call & Surf (T-DSL 6000) auf Call & Surf Comfort Plus (T-DSL 16.000 !!) schmackhaft machen. Ich wiegele ab, es funktioniere alles super, ich hätte genau 6,1 Mbit Download-Rate und sei voll zufrieden.

Eigentlich tut er mir leid, denn ich brauche wirklich nichts (und bin sogar - mit der Telekom !! - voll zufrieden / da nur 80 Meter zum D-SLAM !!!), weiß aber, er muß irgendwas verkaufen, sonst fliegt er irgendwann raus. Also, es koste ja nichts und ich dürfe dafür zusätzlich an 8.500 Hotspots bundesweit surfen und zwar auch flat. Und ich wußte, bei T-DSL 16.000 ist die Upload Rate doppelt so hoch wie jetzt, nämlich 1 Mbit/s. Na gut, das könnte ich gebrauchen, das lockt.

Es kam später sogar noch ein zweiter Router (ein W900V) an

Meine Zustimmung:
Also ich brauchte dann nur einen neuen Router, einen Speedport W701V zum Beispiel (oder vielleicht auch einen W700=Siemens OEM), also ein verkapptes AVM 7050 Gerät namens Fritzbox. Den biete er mir für 59.- Euro an und der könne dann auch DYN-DNS und VPN und A-DSL 16.000. Und der sei voll kompatibel zu meinem Sinus 154 Basic-3. -

Na gut, ich bestelle also, der W701V Router landet auch irgendwann ein (und steht erst mal in der Ecke) und es geht alles wie früher - jedenfalls bis zum 17.6.2008.

und der hier machte ganz dicke Probleme

01 - Nichts geht mehr. - Das Erwachen will geübt werden.

Der erste Versuch:
Am 17.6.2008 ruft dann ein freundlicher Herr D. von der Telekom-Technik an, er sei gerade nebenan in der OVST am DSLAM (OVST steht für Orts-Vermittlungs-Stelle = alter Postbegriff von früher) und stelle jetzt, wie bestellt, meinen DSL Anschluß auf DSL 16.000 um, bzw. er habe das gerade gemacht.

Der Ofen (T-DSL) ist aus, nichts geht mehr.

Der Schock kam "ziemlich" gleich - ich bin offline.
Hätte ich nur auf meinen (Realtime-) Network Überwachungs- Monitor (es sind 8 SNMP Traffic Grapher Fenster) gesehen, alle Server sind offline, das bedeutet, mein DSL ist weg. Ich bitte ihn, nur nicht aufzulegen und mir zu helfen. Ich sei offline. Und ich bekäme den W710V nicht zum Laufen.

Er möge bitte, wenn er aus dem (Telekom-) Gebäude komme, nur nach links schaun, ich werde ihn dort abholen. - Gesagt, getan. Bei mir haben wir dann gemeinsam versucht, dem neuen Speedport W701V die IP Nummer meines Sinus 154 BASIC3 beizubringen, ich hatte es vor ein paar Tagen auch nicht geschafft. Vielleicht weiß er einen speziellen Trick.

Die unlösbare Aufgabe:
Ich habe seit 8 Jahren bei uns im IPW POP Wiesbaden (hinter der Firewall bzw. hinter dem NAT Router) den IP Adressbereich 193.218.31.yyy. Das ist nichts Ungewöhnliches, denn NAT wandelt die IP Adressen (hinter dem Router) ja in die von der Telekom "täglich !!" neu vergebene offizielle Router-Adresse um.

Doch der Speedport hat intern die ersten beiden Nummern-Blöcke seiner (eigenen) IP absolut fest auf 192.168.xxx.yyy geklemmt und ist um Nichts in der Welt zu bewegen, meine gewünschte IP anzunehmen bzw. einzutragen.

02 - Mit allen Tricks ausgetrickst

Die moderne Technik hat Macken.
Nach dem misslungenen Versuch mit dem Speedport habe ich den Sinus 154 Basic-3 wieder eingesteckt, aber oh Schreck, der ging jetzt nicht mehr online. Aha, ausgetrickst oder ?

Ja, der neue Telekom DSLAM, der jetzt 16.000 Mbit/s fähig ist, der könne keine variable Bitrate, der jeweilige Port würde fest auf 16.000 eingestellt und das war's dann. Der Sinus 154 Basic-3 kann (nur?) bis 6.000, (nein er kann sogar 7.200 Kbit/s !!! - habe ich später rausgefunden).

Dem Herrn D. habe ich dann erzählt, es gäbe da noch eine Möglichkeit, die AVM Firmware- Oberfläche auf den Speedport "drüber zu bügeln", dort seien die AVM Originalfunktionen viel weiter offen und komfortabler zu konfigurieren und ich könne mein Problem so lösen. Er hat das natürlich alles gepflegt überhört, denn er dürfte es gar nicht gehört haben. Der Router ist ja noch nicht mal bezahlt.

Also wieder zurück zum alten DSL Port am alten DSLAM
Mein Techniker Herr D. ist dann wieder rüber in den Keller der OVST und hat die Umstellung rückabgewickelt und mein Sinus 154 Basic-3 ging wieder. Doch jetzt waren es nur noch T-DSL 2000 und ich kam nicht mehr über 1.300 Mbit/s. Der Upload war mit 124 KBit/s jetzt richtig lahm (und das Typo3 Backend quälte sich richtig hin).

03- Die Crux mit dem Firmware-Hacken.

18. Juni - Also DSL ging wieder,
wenn auch extrem langsam, aber ok. Und so habe ich gegoogelt, was mit 1.3 Mbit machbar war, und habe die Wikis und die Foren für die "Speedport to AVM" Methodik gefunden. Leider habe ich sehr lange mit Script-Lösungen aus 2007 gearbeitet, bis ich auf die letzten Scripte aus Juni 2008 gestoßen bin. Das ist dort sehr unglücklich gelöst, daß die alten Postings, die ja alle schon lange überholt sind, nicht gelöscht werden. Man findet einfach viel zu viel "Müll" und keine Verweise auf den aktuellen Stand, es ist einfach nur mühselig.

Wenn man es weiß, ist es nämlich ganz einfach.
Es gibt einen Linux-Script von "Jpascher", der aus der angepaßten Telekom Linux-Firmware die Hardware Module entnimmt und dazu aus der äquivalenten AVM Linux-Firmware die Oberfläche und daraus eine neue Firmware, also ein Firmware-Image zusammen baut. Und das ist sogar rückabwickelbar !!

Es hatte aber 2 Nächte gedauert und dann hatte es unter Suse 10.3 ganz plötzlich mit der Juni 2008 Spedport-to-Fritz Variante "problemlos" funktioniert.

Jetzt ist mein "Speedport W701V" ein verkappter "AVM 7170" Router.
Und ich kann die IP im Experten-Modus so einstellen, wie es ein Admin immer gewohnt ist, also völlig frei. Das habe ich natürlich gleich probiert und es klappt. Übrigens benötigt der Speedport/AVM wegen des eingebauten 4-Port-Switches ein Crossover Kabel zu unserem Hauptswitch, der Sinus 154 Basic-3 mit nur einem Port dagegen ein "geradeaus" Kabel.

04 - Kompatibilität, wie schreibt man sowas ?

Realtime Monitoring eines Teils unserer Internet-Server

Also der Speedport/AVM sei kompatibel zum Sinus 154 Basic-3. Ok, dann muss er ja alles das können, das der Sinus 154 vorher auch schon kann/konnte oder ? Und seit 2 1/2 Jahren läuft bei mir der "NOC"-Server (= Network Operation Center) mit SNMP Software, die den Traffic unserer Web-Server im Datakeller live im Sekundentakt anzeigt.

Unser SNMP Traffic Monitoring funktioniert seit Jan 2006.
Dazu läuft dort eine "mrtg" Engine und 10 mal das stg.exe und der Compaq Insight-Manager und alles sogar unter WIN NT 4.0. Das funktioniert super und ich sehe und höre (im ganzen Haus) sofort, wenn es dort klemmt oder gar kracht. Mehr darüber steht hier. Das Protokoll ist UDP, also nicht HTTP oder FTP und es spricht mit ganz speziellen Ports (161 und 162) mit den Servern und Switches, den sogenannten snmp Ports.

Der Ofen (T-DSL) ist aus, schon wieder geht nichts mehr.

Wieder ein Versuch mit dem Speedport/AVM 7170:
Jetzt schnell den Sinus 154 Basic-3 rausgezogen und und mit freudiger Erwartung die beiden Strippen in den Speedport/AVM rein und ??
Es geht. Jedenfalls surfen geht, und E-mail geht und FTP geht. Aber mein Überwachungsserver geht mit allen Submasken komplett auf rot und der Insight Manager tutet, daß die Server alle down wären.

Also mal schnell in die erweiterten Freigaben rein und die Hilfe durchgelesen. Diese erweiterten Freigaben, die der Sinus 154 Basic-3 gar nicht hatte bzw. kannte, die sperren nur den eingehenden Verkehr (von draußen). Also gut, dennoch UDP und alle Ports von 160 bis 162 geöffnet. Doch es geht nicht. Googeln hat auch nichts geholfen. Noch ein Blick auf die Leitungsstatistiken und Eigenschaften. Die (alte) Leitung (am alten Port) hätte sogar 10 Mbit/s insgesamt gekonnt !! Sie mal da. Aber ohne meine totale Serverüberwachung fehlt hier eine essentielle Funktion, die ich keinesfalls mehr missen darf.

05 - Ein Tsunami kommt - Freitag der 13te ? nein, der 27. Juni 2008.

2 Schränke aus dem RDE Datacenter

Der KO Schlag.
Am Freitag dem 27. Juni ruft ein ebenso freundlicher Herr S. der Telekom an und erklärt mir, daß ich einen DSL-Port belege, den er einem anderen Kunden schalten wolle (oder vielleicht auch müsse). Ich habe ihm gesagt, daß der 16.000er Port nicht funktioniert, weil der Sinus 154 Basic-3 kein DSL 16.000 könne und der Speedport W701V kein UDP und ich den DSL Anschluß dringend brauche. Er dürfe mich nicht abklemmen.

Doch Punkt 15.oo Uhr, wenn also bei den "Telekommern" eigentlich keiner mehr "kommt", weil keiner mehr da ist (ein Gerücht muß das sein), bin ich wieder offline und ich muß zum Kunden raus. Das ist natürlich ein Hammer.

Doch das war es gar nicht.
Der Kollege D. von vor zwei Wochen hatte mir freundlicher Weise seine Handy Nummer geben und ich wagte, ihn am heiligen (Telekom-) Feierabend anzurufen. Mit der Entschuldigung meiner Notlage bat ich ihn um Hilfe und er bat mich, den Geschäftskunden-Service mobil zu machen. Das tat ich dann auch und spezifizierte bei dem Call-Center Kollegen Herrn K. G. absolute Dringlichkeit.

Sie werden es nicht glauben.
Ich war schon beim Kunden, um Serverprobleme zu lösen, da klingelt mein Handy und ein Technik-Kollege der Telekom, Herr K., sagt mir, daß er die DSL Leitung wieder oben habe und ob ich das mal prüfen könne.

Zuerst war ich mal platt, es war nämlich erst 16.oo Uhr (und es war an einem Freitag!!!). Dann bat ich ihn, ob ich ihn so gegen 17.30 anrufen dürfe. Nein, nicht nötig, er würde gegen 17.30 mich anrufen. Ich war schon wieder platt. Auch mein Kunde schaute mich fragend an, ob ich im Lotto den 10 Millionen Jackpott geknackt hätte.

06 - Ja, die Glücksfee war da, es ging wieder.

Toll, es geht wieder, so sieht ein Blackout beiuns aus.

Und wirklich, am Freitag dem 27.6.2008 um 17.30 klingelt das Telefon und ich konnte Herrn K. bestätigen, es geht und es geht mit dem alten Sinus 154 Basic-3 Router sogar mit 7.200 Mbit/s, also um 1,1 Mbit/s schneller als jemals zuvor. (Ich hatte bisher immer 6,1 Mbit/s) Das hatte ich mit einem Download einer (Nvidia-) Grafikfirmware getestet. Ich kann es immer noch nicht glauben.

Telekom Kollege K. holte mich aber aus den Wolken zurück und erklärte, daß diese (Zurück-) Einstellung auf dem neuen Port des neuen D-SLAM (also die Einstellung von 16.000 runter auf 6.000) nur temporär sei und bei irgend einem zukünftigen Update (der D-SLAM Software) würde es erst mal überhaupt nicht mehr gehen. Der Vertriebs-Mitarbeiter müsse diese (reduzierte) Geschwindigkeit in das Hardwareprofil meines T-DSL Auftrages einpflegen. Dann erst wäre es langzeitstabil.

Wie dem auch sei, es funktioniert jetzt wieder mit dem alten Sinus 154 Basic-3 und schneller als vorher und meine SNMP Server-Überwachung geht auch (noch oder wieder).

Es stellt sich halt die Frage ? War das, also diese Erkenntnis, nun 2 Tage Arbeit wert ?

Jetzt habe ich also Call & Surf Comfort plus (4), nicht viel mehr als vorher, aber 2 ganze Tage verplempert. Und ich hätte sowieso nicht zu Arcor oder den anderen Problemanbietern gewechselt, ich weiß schon warum.


Also stellt sich jetzt die letzte Frage :
Wie kann ich dem Speedport W701V / AVM Fritzbox 7170 das UDP Protokoll auf Port 161 schmackhaft machen. Dann hätte ich T-DSL 16.000 und könnte noch mehr als nur Tag und Nacht surfen, nämlich endlich 27 Stunden online täglich, endlich .......

und da wäre noch die Frage nach dem Telnet auf die "Fritz-Büchse".......

07 - Mit Akribie und Glück . . . und liebe Helfer gefunden

Der Lichtblick bei UDP auf den Ports 161 und 162.
Wie immer, wenn man es denn weiß, ist es trivial einfach. Irgendwo im Internet habe ich gefunden, daß bei allen Fritz!Boxen auf der WAN Seite dieser

Code: "reject udp any any range 161 162"

die für Profis wichtige UDP Funktion auf den Ports 161 und 162 gänzlich elemeniert. Wer immer das "verbrochen" hatte, er hatte sicher einen nachvollziehbaren logischen Sinn darin gesehen.

Doch daß es aber nirgendwo dokumentiert ist, das ist der große Mist an den Speedports und Fritzboxen W701v und 7050/7170 und sicher den anderen AVM Routern auch.

08 - Also wie bekommt man UDP auf Port 161 zum Laufen ?

Auch hier, wenn man es weiß, wird es wieder ganz einfach. Innerhalb der Linux-Firmware gibt es eine Datei ar7.cfg. Darin sind die Gesetze (die "rules") definiert. Und da finden Sie es mehrfach:

policy = "permit";                               
                               accesslist =
                                             "reject ip any 242.0.0.0 255.0.0.0",
                                             "deny ip any host 255.255.255.255",
                                             "reject ip any 169.254.0.0 255.255.0.0",
                                             "reject udp any any range 161 162",
                                             "reject udp any any eq 111";
policy = "permit";
                                accesslist =
                                             "deny ip any 242.0.0.0 255.0.0.0",
                                             "deny ip any host 255.255.255.255",
                                             "deny udp any any eq 135",
                                             "deny tcp any any eq 135",
                                             "deny udp any any range 137 139",
                                             "deny tcp any any range 137 139",
                                             "deny udp any any range 161 162",
                                             "deny udp any any eq 520",
                                             "deny udp any any eq 111",
                                             "deny udp any any eq 22289",
                                             "deny udp any any eq 1710",
                                             "deny udp any any eq 1048",
                                             "deny udp any any eq 158",
                                             "deny udp any any eq 515";

policy = "permit";
                                accesslist =
                                             "reject ip any 242.0.0.0 255.0.0.0",
                                             "deny ip any host 255.255.255.255",
                                             "reject ip any 169.254.0.0 255.255.0.0",
                                             "reject udp any any range 161 162",
                                             "reject udp any any eq 111";

10 - Mein Weg, UDP zu aktivieren:

Ein Forumsteilnehmer "4your:only" schreibt detailliert, daß man die aktuelle Router- Konfiguration "raus schreibt" (also den Inhalt der Datei ar7.cfg) und dann diese Datei mit dem Notepad++ (einem Unix fähigen Editor!! zum Beispiel) folgendermaßen ergänzt.

In dieser Konfig steht ganz am Anfang nämlich folgendes:
**** FRITZ!Box Fon WLAN Speedport W 701V CONFIGURATION EXPORT
Password=$$$$MBJNDHVVEYC ....... RLUYQ4N1UA4KE2FDJVIA
FirmwareVersion=29.04.57
CONFIG_INSTALL_TYPE=ar7_8MB_xilinx_4eth_2ab_isdn_pots_wlan_13200
OEM=avm
Country=049

NoChecks=yes <<<<<< Dieser Eintrag muß hinzugefügt werden !!!


Dann wird (oder würde) beim (Re-)Importieren dieser Konfig Datei die Checksumme ignoriert. Hinweis: Mist bleibt aber Mist und der Router checkt die Datei nicht mehr auf irgendwelche Fehler und so könnte sich (also Sie können das) der Router selbst killen !!

Weiterhin habe ich einfach alle 161 und 162 in 171 und 172 getauscht (es waren genau 3 Zeilen), denn auf diesen Ports liegt garantiert nichts.

Beim Re-Importieren wird entweder die Datei ar7.cfg neu geschrieben oder deren Inhalt überschrieben. Es ist mir letztendlich völlig wurscht, wie die Firmware das wirklich macht, nach einem Reboot wird diese "ar7.cfg" Datei abgearbeitet bzw. ausgeführt.

12 - Eigentlich braucht man "Telnet" gar nicht, auch wenn es funktioniert. Und so aktiviert man "telnet":

"Telnet" hift dem Linux Kenner, mal in der Box zu schnuppern wie auch in der Buffalo LinkStation. Dort ist auch ein embedded Linux am werkeln und man kann da viel lernen und auch herauslesen. Wenn Sie etwas ändern, ist der jeweilige Server dann tot, und Pech gehabt !! Also Vorsicht, immer mit Bedacht und ohne Stress Schnuppern.

Es ist ganz simpel, eigentlich schon trivial.
Wer hardwaremäßigen Zugang zum Router hat, der soll auch die Hoheit darüber haben. Das ist bei den professionellen Ciscos schon ganz lange Gesetz und hat vielen Admins den Job bzw. "das Leben "gerettet.

An dem Speedport/Fritz!box sind auf der flachen Unterseite versenkt zwei TAE Telefonbuchsen. Sie stecken ganz einfach ein ganz normales analoges 15 Euro Tonwahl- Telefon in eine der beiden TAE Stecker, lauschen auf das "Tut Tut Tut" Freizeichen und wählen #96*7* und bekommen einen kurzen Dauerton als Quittung. Bei mir dann war es ruck zuck gemacht. Ich hatte nur ca. 1 Stunde dieses verdammte uralte analoge Telefon gesucht.

Dann gehen Sie in die DOS Box Ihres Window 2K/XP PC's und tippen telnet_"ip-nummer" und Sie werden nach dem Passwort gefragt, bei mir war es immer noch 0000. Dann sind Sie drinnen.

16 - Also die exportierte Konfig-Datei editieren, wieder zurücksichern und der Restart kommt von alleine.

Am 29.6.2008 um 01.46 kommt der Speedport W701V alias Fritz!box 7170 nach dem "Restore" und "Reset" wieder hoch und UDP zu meinem Switchports und meinen Servern geht (wie früher auf dem Sinus 154 Basic 3).

War das ein Kampf gegen Windmühlen ? Wenn ja, dann war es so ziemlich der blödeste unnütze und überflüssige Kampf meiner EDV Laufbahn.

Also es funktioniert sogar ohne ein Bißchen "telnet" oder "vi" zu können. Nur den Notepad++ müssten Sie sich herunter laden, sonst geht es nicht. Mein Anschluß ist immer noch temporär auf T-DSL 6000 gestellt, damit der Sinus 154 funktioniert. Jetzt geht der Speedport auch. Und die Geschwindigkeit geht sogar viel höher !!! (8128 kBit/s vom Netz und 1184 kBit/s ins Netz als Upload. Was will ich mehr ??)

17 - Der Stand der Dinge - der W701V hängt am neuen DSLAM.

Jetzt könnte der neue Port am neuen DSLAM auch auf T-DSL 16.000 geschaltet werden (oder dort bleiben) und er wird beim Update zumindest nicht abstürzen.

Also neuer DSLAM  und neuer Speedport W701V alias AVM Fritzbox 7170 vertragen sich gut und es funktioniert so, wie es eigentlich sein sollte.

Und was mache ich mit meinen vielen Sinus 154 Basic 3 ????????

18 - Die Lösung (oder besser "Das Paradoxum").

Das Paradoxe an der ganzen Situation ist, daß die "Telekommer" dafür gar nichts können, denn die "kommen" ja (zu uns jedenfalls) recht schnell und sie versuchen zu helfen, wo sie nur können, sogar Freitags nach Dienstschluß. Doch wo sie es (auch) nicht wissen, geht's halt auch nicht.

Zurück zum Speedport. Eigentlich hätte ich den aufwändigen "Firmware Hack", also die "SP-to-Fritz" Umstellung gar nicht gebraucht.

20 - Der ganz einfache Weg wäre . . . . .

Doch zuvor nochmal die 3 Forderungen, die ich bei der Umstellung auf T-DSL 16.000 hatte:

  1. Der Router muß eine IP Nummer aus meinem Kontingent benutzen
  2. Meine Server-Überwachung per UDP muß nach wie vor laufen
  3. Ich brauche wieder einen zweiten gleichartigen Router wegen der Redundanz im Falle eines Fehlers

Die IP Nummer kann man per Web Interface bei der Speedport Firmware nicht beliebig umstellen, die ersten beiden Nummernblöcke sind fest vorgegeben bzw. per Webmaske nicht änderbar. In der exportiertenTextdatei könnte man das schon eintragen.

Die Abschaltung der UDP Ports 161 und 162 kann man auch in dem exportierten Textfile löschen oder verändern (siehe oben).

Nur muß man überhaupt erst einmal wissen, daß dann die Checksumme in dem modifizierten Konfig File nicht mehr stimmt und man eine Zeile (NoChecks=yes) zum Abschalten der Checksummenprüfung einbauen kann und muß. So einfach ist das. Und die AVM Leute wissen das, dokumentieren das aber nicht. So etwas kann sowieso nur ein Profi handhaben. Es gibt doch in der AVM Firmware den Expertenmodus. Im Speedport dagegen nicht, doch da könnte man sich helfen.

Wer also mit der Speedport Web-Oberfläche leben kann, der konfiguriere so viel wie es geht, exportiere die Konfiguration in eine Textdatei auf die lokale Platte und editiere diese mit dem Notepad++ nach seinen Wünschen.

Dann reimportiere er diese Textdatei in den Speedport zurück und die Wünsche sind erfüllt. Da wir inzwischen noch einen W900V bekommen haben, werde ich das jetzt auch noch mal testen mit der original Telekom Firm- bzw Software.

22 - Und der Schluß von der "Geschicht",
3 Minuten reichen nicht.

Aber in 5 Minuten haben Sie den Speedport dort, wo Sie ihn hin haben möchen. Der Internet- Fachman spricht inzwischen auch vom sogenannten "Tot-Googeln". Ich habe für die obige Update-Erkenntnis mit meiner Problemlösung 3 ganze Tage (mit je über 10 Stunden) verplempert. Ganz sicher bin ich jetzt schlau, sogar ganz schlau und kann sogar unter Suse Linux fremde Firmware hacken und auch noch neu aufspielen.

Doch brauche ich das wirklich ? Muß das alles sein ?

Es hätte alles so einfach sein können. Man könnte durchaus in der Telekom- Firmware einen Expertenmodus einbauen und den per Kennwort erst mal ausblenden oder verstecken. Das Kennwort mit den versteckten Features sollte aber im Handbuch stehen. Auch die Telekom-Kunden haben doch schon einiges dazu gelernt.

Wir sind die Kunden.

Sowohl die Telekom wie auch AVM sollten beachten.
Wir sind "die Kunden".
"Das Volk" sind wir seit 1989 sowieso.

Und wir haben nicht nur das Recht, nichts mehr zu kaufen, sondern auch zu kündigen, wenn sich nichts (zum Positiven) ändert.

Also ran an die Aufgaben, die vor Ihnen stehen. Ich habe schon mehr als 3.000 Seiten hier geschrieben und Sie ? Schnuppern Sie auch mal auf www.rde.de

Zurück zur Startseite ----- © 2009 / 2018 - Copyright by Dipl. Ing. Gert Redlich - Zum Telefon - - - - NEU : Zum Flohmarkt