Sie sind hier : Homepage →  Linux (6) Ein Webtropia root-Server→  Der Webtropia Rescue-Modus→  Die Installation nachbearbeiten

So funktioniert die neue Installation nicht . . .

Wie auf dieser Seite schon beschrieben, wird unsere eigene opensuse Installation in einer virtuellen Maschine installiert und auf die Platte in die dortigen Partitionen (md0 ist ja swap), also md1 als "/boot" und md2 als "/" geschrieben.

Wichtig : Die aktuelle Netzwerk-Konfiguration orientiert sich natürlich an dem (Software-) Sockel, den der debian Hypervisor noch oben zur KVM durchreicht bzw. anbietet.

Und das ist hier ein Intel Netzwerkkarte vom Typ ...... - Doch physikalisch hat die darunter liegende Hardware (also das MSI Motherboard) einen Realtek Chip vom Typ ......

Und so müssen wir die Konfigurationsdateien mit denen der gesicherten opensuse Ur-Installation ersetzen. Denn unser neuer eigener opensuse Hypervisor soll ja direkt auf der Hardware aufsetzen und seinerseits diesen Port nach oben zu den späteren VMs durchreichen.
.

Unsere Sicherung auf das Rescue-System kopieren

Auch hier wiederum kopieren wir die beiden gesicherten tar.gz Files von unsererm lokalen NAS per winscp wieder zurück - sogar als user "root" - gleich auf die Festplatte, also in das vorher gemountete /root System der opensuse Installation.

Aus den Archiven kopieren wir mit dem "mc" (der entpackt die gepackten Archive per Klick) die wenigen "config" Dateien über die vorhandenen drüber.

Soeben habe ich verglichen, daß die RAM Images der wbetroipa Ur-version und unserer Nachinstallion sehr ähnlich (groß) sind und das könnte dann so auch booten. Tut es aber nicht !!!!
.

An welchen Ecken muß ich nachbessern ?

Eines wäre bei der eigenen Installation wichtig gewesen : Die Firewall muß bei unserer Neu-Installation erst mal ganz abgeschaltet werden und SSH muß aktiviert werden, sonst kann man auf die Neuinstallation überhaupt nicht zugreifen, käme sie den überhaupt hoch. - Jetzt könnte man einen Neustart wagen. Also also mal sehen.

Und man sollte vor dem Ausstieg aus der Rescue-Version das "umount all" nicht vergessen, damit beim brutalen Hardware-Reset nicht der ganze mühsam eingerichtete Partitionsbereich kaputt geht.

Es geht immer noch nicht, denn in /etc/default/ stehen die falschen ehemals QEMU-Platten drinnen. Auch das muß von der Ur-version geholt werden, sonst bootet das System nicht. Das geht aber auch nicht, weil in der webtropia UR-Version drei ganz andere UUIDs für md0 bis md2 eingetragen sind, die unsere eigene Installation schon wieder überschrieben hatte. Und damit bootet die Ur-Version auch nicht mehr. Also das mit den UUIDs ist sehr sehr mühsam, auch wenn es laut der Experten sinnvoll sei.
.

Zurück zur Startseite ----- © 2009 / 2018 - Copyright by Dipl. Ing. Gert Redlich - Zum Telefon - - - - NEU : Zum Flohmarkt