Sie sind hier : Homepage →  Linux (1) Server-Installation→  k) XEN Server Okt. 2014→  opensuse 12.3 - wenn die Gäste nicht mehr starten

Es gibt bei opensuse 12.3 und xen ganz "verrückte" Fehler

Nehmen wir an, Ihre opensuse 12.3 DOM 0 auf dem xen-Server läuft endlich stabil, Sie haben ihn mehrfach mit "reboot" völlig autark hochgefahren und geprüft und jetzt gehts ans Bereinigen von nicht gebrauchten Modulen.

An der "DOM 0" (bzw. an der gesamten Hardware - es sind bei uns HP Proliant Profi Server) hängen weder Soundkarten noch Drucker dran, noch wird auf der DOM 0 irgendwo eine Anwendung mit Ghost oder Postscript genutzt, da könnte man doch den "cups" Dienst und den "alsa" Sound Dienst bereinigen / löschen.

Und der Server mit seinen 8 oder mehr VMs läuft weiter, jedenfalls bis zum nächsten "reboot". Und dann geht nichts mehr. Die VMs straten nicht mehr.

Völlig crude Fehler tauchen plötzlich auf. Irgendwo lesen sie etwas von einer libesd.so.0 - eine 32 bit Library. Mit yast suchen Sie die und stellen mit Schrecken fest, das ist ja eine Sound Bibliothek für GNOME - und Sie haben weder Gnome noch Sound auf der Kiste.

Sie rufen YAST auf, lassen nach "libesd" suchen und klicken diese "libesd" an und installieren sie. Doch damit installieren Sie auch (wieder) den ganzen unnützen Sound Kram von "alsa" und potz Blitz, auf einmal geht die virtlib und die xen - VM - alles wie zuvor. Was hat der Sound mit der Virtualisierung zwangsweise zu tun ?

Der gestandene EDV Mensch unterdrückt mühsam das Fluchen. Wer hat soetwas Beklopptes programmiert ??

.

Zurück zur Startseite ----- © 2009 / 2018 - Copyright by Dipl. Ing. Gert Redlich - Zum Telefon - - - - NEU : Zum Flohmarkt